-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
devel/hs-vector: update to vector-0.13.2.0
# Changes in version 0.13.2.0 * Strict boxed vector `Data.Vector.Strict` and `Data.Vector.Strict.Mutable` is added (#488). it ensures that all values in the vector are evaluated to WHNF. * `DoNotUnboxStrict`, `DoNotUnboxLazy`, and `DoNotUnboxNormalForm` wrapper are added for defining unbox instances for types that contain not unboxable fields. [#503](haskell/vector#506), [#508](haskell/vector#508) * `spanR` and `breakR` were added [#476](haskell/vector#476). They allow parsing vector from the right. * We had some improvements on `*.Mutable.{next,prev}Permutation{,By}` [#498](haskell/vector#498): * Add `*.Mutable.prevPermutation{,By}` and `*.Mutable.nextPermutationBy` * Improve time performance. We may now expect good specialization supported by inlining. The implementation has also been algorithmically updated: in the previous implementation the full enumeration of all the permutations of `[1..n]` took Omega(n*n!), but it now takes O(n!). * Add tests for `{next,prev}Permutation` * Add benchmarks for `{next,prev}Permutation` * Cabal >= 3.0 is now required for building package (#481). * `vector:benchmarks-O2` public sublibrary containing benchmarks is added (#481). * Type family `Mutable` provides instances for arrays from `primitive`. * Various documentation improvements.
- Loading branch information
1 parent
ae35d07
commit b05c54c
Showing
5 changed files
with
164 additions
and
79 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,14 +1,19 @@ | ||
# $NetBSD: Makefile,v 1.20 2024/05/09 01:32:19 pho Exp $ | ||
# $NetBSD: Makefile,v 1.21 2025/01/29 17:21:33 pho Exp $ | ||
|
||
DISTNAME= vector-0.13.1.0 | ||
PKGREVISION= 2 | ||
DISTNAME= vector-0.13.2.0 | ||
CATEGORIES= devel | ||
|
||
MAINTAINER= pho@cielonegro.org | ||
COMMENT= Efficient Arrays for Haskell | ||
LICENSE= modified-bsd | ||
|
||
# lib:vector | ||
.include "../../devel/hs-primitive/buildlink3.mk" | ||
.include "../../devel/hs-vector-stream/buildlink3.mk" | ||
|
||
# lib:benchmarks-O2 | ||
.include "../../devel/hs-random/buildlink3.mk" | ||
.include "../../devel/hs-tasty/buildlink3.mk" | ||
|
||
.include "../../mk/haskell.mk" | ||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,16 +1,22 @@ | ||
# $NetBSD: buildlink3.mk,v 1.21 2024/05/09 01:32:19 pho Exp $ | ||
# $NetBSD: buildlink3.mk,v 1.22 2025/01/29 17:21:33 pho Exp $ | ||
|
||
BUILDLINK_TREE+= hs-vector | ||
|
||
.if !defined(HS_VECTOR_BUILDLINK3_MK) | ||
HS_VECTOR_BUILDLINK3_MK:= | ||
|
||
BUILDLINK_API_DEPENDS.hs-vector+= hs-vector>=0.13.1 | ||
BUILDLINK_ABI_DEPENDS.hs-vector+= hs-vector>=0.13.1.0nb2 | ||
BUILDLINK_API_DEPENDS.hs-vector+= hs-vector>=0.13.2 | ||
BUILDLINK_ABI_DEPENDS.hs-vector+= hs-vector>=0.13.2.0 | ||
BUILDLINK_PKGSRCDIR.hs-vector?= ../../devel/hs-vector | ||
|
||
# lib:vector | ||
.include "../../devel/hs-primitive/buildlink3.mk" | ||
.include "../../devel/hs-vector-stream/buildlink3.mk" | ||
|
||
# lib:benchmarks-O2 | ||
.include "../../devel/hs-random/buildlink3.mk" | ||
.include "../../devel/hs-tasty/buildlink3.mk" | ||
|
||
.endif # HS_VECTOR_BUILDLINK3_MK | ||
|
||
BUILDLINK_TREE+= -hs-vector |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,5 +1,5 @@ | ||
$NetBSD: distinfo,v 1.14 2023/10/28 17:01:01 pho Exp $ | ||
$NetBSD: distinfo,v 1.15 2025/01/29 17:21:33 pho Exp $ | ||
|
||
BLAKE2s (vector-0.13.1.0.tar.gz) = ba1c5ffe4c66ffd950e336492d2a257ff73f3d7a55e0c97c957f8a00024885e5 | ||
SHA512 (vector-0.13.1.0.tar.gz) = 7c29df2449ee3858906c324cd8bc9128d97ab733bb11a010388cc06f85134cfeaea087ceefc2e3ca5ba06d6921f8cd2bb53c5dbc61d0e59cf004075b5c1d15c2 | ||
Size (vector-0.13.1.0.tar.gz) = 156855 bytes | ||
BLAKE2s (vector-0.13.2.0.tar.gz) = 0345aada615bc6c612549309c0cb2b7f43a45e77771873d5afd4aba508b54862 | ||
SHA512 (vector-0.13.2.0.tar.gz) = d52ad78c8859284bce141254f6a29b0e0175a9db8c15505bc0e35fed1b9027736ad00a42f55d465c81b4738be67c6655cc11276ca85af3c740f55c86708e15a3 | ||
Size (vector-0.13.2.0.tar.gz) = 185739 bytes |