Skip to content

Commit

Permalink
URL & Pypi info updated
Browse files Browse the repository at this point in the history
  • Loading branch information
Aurelio Lopez-Fernandez committed Jan 30, 2023
1 parent 80aea35 commit 98b00ac
Show file tree
Hide file tree
Showing 5 changed files with 13 additions and 17 deletions.
5 changes: 0 additions & 5 deletions README.rst
Original file line number Diff line number Diff line change
Expand Up @@ -13,11 +13,6 @@ pyEnGNet: optimized reconstruction of gene co-expression networks using multi-GP
:alt: Documentation Status


.. image:: https://mybinder.org/badge_logo.svg
:target: https://mybinder.org/v2/gh/aureliolfdez/pyengnet/master
:alt: Binder


.. image:: https://img.shields.io/github/stars/aureliolfdez/pyengnet.svg
:target: https://github.com/aureliolfdez/pyEnGNet/stargazers
:alt: GitHub stars
Expand Down
5 changes: 0 additions & 5 deletions docs/index.rst
Original file line number Diff line number Diff line change
Expand Up @@ -18,11 +18,6 @@ Welcome to pyEnGNet's documentation!
:alt: Documentation Status


.. image:: https://mybinder.org/badge_logo.svg
:target: https://mybinder.org/v2/gh/aureliolfdez/pyengnet/master
:alt: Binder


.. image:: https://img.shields.io/github/stars/aureliolfdez/pyengnet.svg
:target: https://github.com/aureliolfdez/pyEnGNet/stargazers
:alt: GitHub stars
Expand Down
1 change: 1 addition & 0 deletions docs/releases/v0.1.rst
Original file line number Diff line number Diff line change
Expand Up @@ -7,5 +7,6 @@ Changelog

Initialize the project by Aurelio Lopez-Fernandez et al. in Jan 2023.

* v<0.0.2>, <30/01/2023> -- Documentation & links updated
* v<0.0.1>, <30/01/2023> -- Documentation update & multi-GPU execution error solved.
* v<0.0.0>, <27/01/2023> -- Initial release.
2 changes: 1 addition & 1 deletion pyengnet/version.py
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
"""
File to store the software version.
"""
__version__ = '0.0.1'
__version__ = '0.0.2'
17 changes: 11 additions & 6 deletions setup.py
Original file line number Diff line number Diff line change
@@ -1,18 +1,23 @@
from setuptools import setup, find_packages
import os
from os import path

with open('README.md', 'r', encoding='utf-8') as fh:
long_description = fh.read()
this_directory = path.abspath(path.dirname(__file__))

# read the contents of README.rst
def readme():
with open(path.join(this_directory, 'README.rst'), encoding='utf-8') as f:
return f.read()

# Setting up
setup(
name="pyengnet",
version='0.0.1',
version='0.0.2',
author="Aurelio Lopez-Fernandez",
author_email="alopfer1@upo.es",
description='pyEnGNet: optimized reconstruction of gene co-expression networks using multi-GPU',
long_description_content_type="text/markdown",
long_description='pyEnGNet: optimized reconstruction of gene co-expression networks using multi-GPU',
description='pyEnGNet: optimized reconstruction of gene co-expression networks using multi-GPU',
long_description=readme(),
long_description_content_type="text/x-rst",
packages=['pyengnet'],
install_requires=['numpy', 'tqdm', 'multiprocess', 'pandas', 'matplotlib', 'networkx', 'scipy'],
keywords=['python', 'multiGPU', 'bioinformatics', 'gene networks'],
Expand Down

0 comments on commit 98b00ac

Please sign in to comment.